本站停止维护,已转移至laravel学习网;欢迎大家移步访问!

解决Laravel/lumen安装Dingo API出现Can only install one of: illuminate/container[v5.1.20, v5.2.45].问题

出现的原因:

今天我在lumen中安装拓展,出现了Can only install one of: illuminate/container的问题,我检查composer.json;发现了require中出现"dingo/api": "0.10.*" ;应该是其他工作人员安装的拓展包导致了Can only install one of: illuminate/container[v5.1.20, v5.2.45].问题,应该是版本问题;那么我来解决掉这个问题

解决办法:

1. 在composer.json中删除原来安装的"dingo/api": "0.10.*",这时候我们安装其他拓展,发现不会有问题了;证明就是dingo/api的锅!

2.如果你确实需要安装dingo/api,那么执行如下代码即可正常安装

composer require dingo/api:1.0.x@dev


转载请注明 :一沙网络原文出处:http://bbs.earnp.com/article/385
问题交流群 :562864481
2
打赏
发布时间 :2017-05-25 11:38:28
分享

0 个评论

    还没有评论,感觉来抢沙发吧!

要回复文章请先登录注册